真牛论坛

 找回密码
 立即注册
搜索
查看: 52|回复: 2

[源码] 开源CF网截过362源码 易语言源码

[复制链接] [查看百度是否已收录]
灌水成绩
 169

 181

 989

主题
帖子
积分
等级头衔

 ID : 245

斗灵

积分成就    威望 : 1
   贡献 : 51
   铜钱: 989
   违规 : 0
   在线时间 :27 小时
  注册时间 :2018-12-7
  最后登录 :2019-11-10
勋章

锋芒初露

联系方式

发表于 2019-11-4 11:56:44 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
CF网截过检测视频

从0开始

教学开始 首先我们需要编程工具易语言!

网截我们安装组件 首先我们添加一下模块 编写比较方便+

我们安装网截网络环境没安装网截没法启动哦

安装好了现在我们在添加一个编辑框方便查看游戏里面的数据!
教学继续安装好编辑框后我们开始写代码 这是调发送

寻找文本就是检查游戏端口发出的数据就叫做寻找文本找到我们可以拦截 释放 或者默认返回

返回(1)拦截 返回(2)释放 返回(0)默认返回

一般我们抓到检测数据第一时间就是拦截,错了拦截一些检测数据属于静态的可以进行拦截 如果检测属于动态拦截会出03 网络异常等等这些我们只能用替换处理。

.版本 2

.如果真 (寻找文本 (发送数据, “0303”, 1, 假) ≠ -1)
编辑框1.加入文本 (“实名认证拦截成功” + #换行符)
返回 (1)
ntcls_daemon这是发出实名检测的进程
这是游戏实名认证特征返回1拦截即可不用实名进入游戏!

接下来我们找游戏数据 这是我抓游戏端口的数据这文本,密密麻麻的数据是否看了都头晕我们应该怎么找检测特征呢 我这个文本里面数据属于静态的不会经常变动 这也是362检测也是属于静态数据可以直接拦截即可奔放
我们数到27位数进行拦截 一般我们就这样拦截他的一部分是吧,这些都是错误的 拦截一部分是检测特征属于过动态数据
我们静态数据最后 整条处理32位即可 这种数据不会经常变动整条寻找端口文本进行拦截就对了 把他处理了检测就不会出来

只要查找到数据即会发送出编辑框我们也可以方便看到例如这样子 后位数的0可以去掉0代表空包

开源CF网截过362源码 易语言源码

开源CF网截过362源码 易语言源码


完整源码下载:
游客,如果您要查看本帖隐藏内容请回复


贴出部分源码:
.版本 2
.支持库 eNetIntercept

.如果真 (寻找文本 (调用者信息.取进程名 (), “ntcls_daemon”, , 假) ≠ -1)
    发送数据 = 天狼_字节集到十六进制文本 () (网络数据.到字节集 ())
    .如果真 (寻找文本 (发送数据, “0303”, 1, 假) ≠ -1)
        编辑框1.加入文本 (“实名认证拦截成功” + #换行符)
        返回 (1)
    .如果真结束

.如果真结束
.如果真 (寻找文本 (调用者信息.取进程名 (), “crossfire.exe”, , 假) ≠ -1)
    封包数据 = 网络数据.到字节集 ()
    发送数据 =天狼_字节集到十六进制文本 () (网络数据.到字节集 ())
    编辑框1.加入文本 (“1080:” + #换行符)
    返回 (0)
    .如果真 (寻找文本 (发送数据, “F1320001EC0030000026000000126011958D00240188051001000A0001020800000000020002000004”, 1, 假) ≠ -1)
        编辑框1.加入文本 (“362数据” + #换行符)
        返回 (1)
    .如果真结束
    .如果真 (寻找文本 (发送数据, “F1320001EC0030000026000000158E0573CB00240108051001002A0821220940040000000002000004”, 1, 假) ≠ -1)
        编辑框1.加入文本 (“362数据” + #换行符)
        返回 (1)
    .如果真结束
    .如果真 (寻找文本 (发送数据, “F16D0001EC006B00002600000019BDD55D76005F0000180115841008802158B8400208248B574EC4623EC1F3177AF99CAC0A”, 1, 假) ≠ -1)
        编辑框1.加入文本 (“362数据” + #换行符)
        返回 (1)
    .如果真结束
    .如果真 (寻找文本 (发送数据, “F1320001EC00300000260000002127F89C9C00240108051000080A0820202804042200800002000004”, 1, 假) ≠ -1)
        编辑框1.加入文本 (“362数据” + #换行符)
        返回 (1)
    .如果真结束


.如果真结束
返回 (0)





本文章来源:颜兮论坛 - www.yanxn.com 转载请注明出处
----------------
上一篇:怎么给软件弄一个透明背景图源码,我教你
下一篇:9.22 游戏基质 攻击CALL 人物基质 视距基址 等等
灌水成绩
 6

 36

 68

主题
帖子
积分
等级头衔

 ID : 770

斗者

积分成就    威望 : 0
   贡献 : 0
   铜钱: 68
   违规 : 0
   在线时间 :2 小时
  注册时间 :2019-3-15
  最后登录 :2019-11-2
勋章
联系方式

发表于 2019-11-4 23:06:58 | 显示全部楼层
支持一下楼主,感谢颜兮辅助网
回复 支持 反对

使用道具 举报

灌水成绩
 198

 313

 1519

主题
帖子
积分
等级头衔

 ID : 53

斗王

积分成就    威望 : 25
   贡献 : 49
   铜钱: 1519
   违规 : 0
   在线时间 :32 小时
  注册时间 :2018-9-1
  最后登录 :2019-11-12
勋章

锋芒初露

联系方式

发表于 2019-11-5 09:26:21 | 显示全部楼层
先收藏了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表